Membagi Bandwidth Untuk Pelanggan yang Berbeda

Setiap ISP yang berkembang pasti memiliki pelanggan yang berbeda-beda tipe dan biasanya dapat dikategorikan dengan berapa besar uang yang harus dibayar ke ISP tiap bulannya. Dalam contoh berikut ini kita kategorikan pelanggan corporate atau perusahaan dan pelanggan biasa atau rumahan.

Pertama - tama lakukan mangle

Aplikasi mangle ini dapat ditemukan dengan cara mengklik perintah "IP" pada software Winbox lalu nanti akan terdapat banyak pilihan, kita pilih firewall dan nantinya akan ada pada toolbarnya tulisan mangle, lalu kita klik. apabila software winbox anda tidak ada, anda dapat mendownloadnya Disini.

setelah dapat lakukan perintah - perintah dibawah ini

Untuk trafik upload corporate

/ip firewall mangle add chain=prerouting src-address=192.168.1.2 in-interface=Local action=mark-packet new-packet-mark=corporate-up passthrough=no
Perintah di atas merupakan perintah untuk trafik upload corporate dimana digunakan ip 192.168.1.2 sebagai target host corporate. Untuk passthrough-nya di set no.

Untuk trafik download corporate
/ip firewall mangle add chain=forward src-address=192.168.1.2 action=mark-connection new-connection-mark=corporate-conn passthrough=yes /ip firewall mangle add chain=forward connection-mark=corporate-conn in-interface=Public action=mark-packet new-packet-mark=corporate-down passthrough=no
Bila pada perintah sebelumnya dilakukan untuk trafik upload, maka pada perintah di atas digunakan untuk trafik download target host corporate dengan ip 192.168.1.2. Terdapat 2 konfigurasi untuk membuat trafik download corporate. Perbedaan terpenting dari keduanya adalah pada konfigurasi passthrough-nya, di konfigurasi pertama passthrough-nya yes sedangkan pada konfigurasi kedua passthrough-nya = no.


Untuk trafik upload personal
/ip firewall mangle add chain=prerouting src-address=192.168.1.3 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no /ip firewall mangle add chain=prerouting src-address=192.168.1.5 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no /ip firewall mangle add chain=prerouting src-address=192.168.1.10 in-interface=Local action=mark-packet new-packet-mark=personal-up passthrough=no Perintah di atas merupakan perintah untuk membuat trafik upload personal, dimana terdapat 4 host. Masing-masing ip-nya diset yaitu dengan IP 192.168.1.3 , 192.168.1.5, dan 192.168.1.10 personal di set up.

Untuk trafik download personal
/ip firewall mangle add chain=forward src-address=192.168.1.3 action=mark-connection new-connection-mark=personal-conn passthrough=yes /ip firewall mangle add chain=forward src-address=192.168.1.5 action=mark-connection new-connection-mark=personal-conn passthrough=yes /ip firewall mangle add chain=forward src-address=192.168.1.10 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=Public action=mark-packet new-packet-mark=personal-down passthrough=no

Bila pada perintah sebelumnya dilakukan untuk trafik upload, maka pada perintah di atas digunakan untuk trafik download target host personal dengan IP 192.168.1.3 , 192.168.1.5 dan 192.168.1.10 .pada perintah diatas passthrough antara upload berbeda dengan download, bedanya adalah pada upload passthoughnya no sedangkan pada download passtoughtnya yes

Apabila konfigurasi diatas sudah benar maka akan terlihat seperti gambar di bawah ini:

Konfigurasi mangle


Kemudian setelah selesai di mangle, kita lanjut ke pembuatan queue tree :
/queue tree add name=down parent=Local queue=default

/queue tree add name=up parent=global-in queue=default

Gambar dibawah ini merupakan hasil konfigurasi diatas :


Untuk download kita menggunakan in-interface kita dalam hal ini Local, sedangkan untuk upload kita menggunakan global-in.

selanjutnya kita tambahkan type baru di queue :
yang harus kita tambahkan melihat skenario diatas adalah PCQ untuk paket corporate 256 kbps (1:1) dan paket personal 256 kbps (1:3).
Untuk paket corporate kita langsung menetapkan angka 256 kbps, sedangkan untuk personal kita tidak dapat menetapkan angka disini karena bandiwdth yang akan diterima oleh paket personal tergantung seberapa banyak user yang online.

  1. Jika hanya 1 orang online akan mendapatkan bandwidth penuh 256 kbps.
  2. Jika 2 orang online maka masing-masing akan mendapatkan 128 kbps.
  3. Jika 3 orang online maka masing-masing akan mendapatkan 64 kbps.


/queue type add name=256-down kind=pcq pcq-rate=256k pcq-classifier=dst-address pcq-total-limit=2000
Perintah di atas adalah untuk membuat type queue dengan nama 256-down dengan jenis pcq dan memiliki rate download sebesar 256kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :/queue type add name=256-up kind=pcq rate=256k pcq-classifier=src-address pcq-total-limit=2000
Perintah di atas adalah untuk membuat type queue untuk upload dengan nama 256-up dengan jenis pcq dan memiliki rate upload sebesar 256kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

/queue type add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000

Perintah di atas adalah untuk membuat type queue dengan nama auto-down dengan jenis pcq dan memiliki rate download sebesar 0kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

/queue type add name=auto-up kind=pcq rate=0 pcq-classifier=src-address pcq-total-limit=2000

Perintah di atas adalah untuk membuat type queue dengan nama auto-up dengan jenis pcq dan memiliki rate download sebesar 0kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

Bila konfigurasinya sudah benar maka akan terlihat seperti gambar di bawah ini:

Gambar Queue Types

Setelah membuat queue type selanjutnya kita menambahkan queue tree untuk paket corporate dan personal

Paket corporate

/queue tree add name=corp-down packet-mark=corporate-down parent=down queue=256-down
Perintah di atas digunakan untuk membuat paket download queue tree corporate dengan kapasitas rate 256kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

/queue tree add name=corp-up parent=up packet-mark=corporate-up queue=256-up
Perintah di atas digunakan untuk membuat paket upload queue tree corporate dengan kapasitas rate 256kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

Gambar dibawah ini merupakan hasil konfigurasi diatas :


Paket personal

/queue tree add name=per-down packet-mark=personal-down parent=down queue=auto-down max-limit=256k
#Perintah di atas digunakan untuk membuat paket download queue tree personal dengan kapasitas rate maksimum 256kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

/queue tree add name=per-up parent=up packet-mark=personal-up queue=auto-up max-limit=64k
Perintah di atas digunakan untuk membuat paket upload queue tree personal dengan kapasitas rate maksimum 64kbps. Untuk lebih jelasnya dapat dilihat pada gambar di bawah ini :

Gambar dibawah ini merupakan hasil konfigurasi diatas :

Bila konfigurasinya sudah benar maka akan terlihat seperti gambar di bawah ini:


Pengetesan trafik
Pada gambar dibawah ini merupakan pengetesan trafic pada IP 192.168.1.3 ,192.168.1.5 dan 192.168.1.10 yang memiliki bandwith 256kbps dibagi dengan 3, karna ketiga usernya sedang melakukan download


Pada gambar dibawah ini merupakan pengetesan trafic pada IP 192.168.1.2 yang memiliki bandwith 256kbps.

Gambar dibawah ini merupakan indikasi ketika kita melakukan download



1 komentar:

Anonim mengatakan...

mantappp...

Poskan Komentar

Comment